HDU 1234(开门人和关门人-scanf解决带注释数字读入)

开门人和关门人

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 7841    Accepted Submission(s): 4066



Problem Description
每天第一个到机房的人要把门打开,最后一个离开的人要把门关好。现有一堆杂乱的机房签 
到、签离记录,请根据记录找出当天开门和关门的人。 
 


Input
测试输入的第一行给出记录的总天数N ( > 0 )。下面列出了N天的记录。 
每天的记录在第一行给出记录的条目数M ( > 0 ),下面是M行,每行的格式为 

证件号码 签到时间 签离时间 

其中时间按“小时:分钟:秒钟”(各占2位)给出,证件号码是长度不超过15的字符串。

 


Output
对每一天的记录输出1行,即当天开门和关门人的证件号码,中间用1空格分隔。 
注意:在裁判的标准测试输入中,所有记录保证完整,每个人的签到时间在签离时间之前, 
且没有多人同时签到或者签离的情况。 
 


Sample Input
3 1 ME3021112225321 00:00:00 23:59:59 2 EE301218 08:05:35 20:56:35 MA301134 12:35:45 21:40:42 3 CS301111 15:30:28 17:00:10 SC3021234 08:00:00 11:25:25 CS301133 21:45:00 21:58:40
 


Sample Output
ME3021112225321 ME3021112225321 EE301218 MA301134 SC3021234 CS301133
 


Source
 


Recommend
JGShining
 

利用Scanf可以解决时间的读入

%d:%d:%d的占位符

占位符中如果用符号,则表示读取这个符号,但不做任何事

#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<cmath>
#include<functional>
#include<algorithm>
#include<cctype>
#include<iostream>
using namespace std;
int t,n;
struct ID
{
	char s[16];
	int in1,in2,in3,out1,out2,out3;
	int intime(){return in1*3600+in2*60+in3;}
	int outtime(){return out1*3600+out2*60+out3;}
	friend bool operator<(ID a,ID b){return a.intime()<b.intime();}
	friend bool operator>(ID a,ID b){return a.outtime()>b.outtime();}

}p,amin,amax;
int main()
{
	cin>>t;
	while (t--)
	{
		int n;
		cin>>n;
		scanf("%s %d:%d:%d %d:%d:%d",p.s,&p.in1,&p.in2,&p.in3,&p.out1,&p.out2,&p.out3);
		amin=amax=p;
		for (int i=2;i<=n;i++)
		{
			scanf("%s %d:%d:%d %d:%d:%d",p.s,&p.in1,&p.in2,&p.in3,&p.out1,&p.out2,&p.out3);
			if (p<amin) amin=p;
			if (p>amax) amax=p;
		}
		printf("%s %sn",amin.s,amax.s);
	}
	return 0;
}


POJ 1113(Wall-Quickhull)

Language:
Wall
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 24604   Accepted: 8183

Description

King想在自己的n个城堡外建Wall,使Wall与任一城堡距离至少为L且能围住它的城堡. 


求Wall最短长度. 

Input

第一行为 N (3 <= N <= 1000) 和 L(1 <= L <= 1000).
接下来 N 行,每行为城堡坐标Xi,Yi (-10000 <= Xi, Yi <= 10000).

Output

输出一行Wall最短长度.

Sample Input

9 100
200 400
300 400
300 300
400 300
400 400
500 400
500 200
350 200
200 200

Sample Output

1628

Hint

结果四舍五入就可以了

Source

易证Wall最短长度=对城堡求凸包的周长+2πL

这里介绍一个凸包求法QuickHull

备注Quickhull-

s表示向量CACB的叉积(在上一求得,用于求距离),初始化为0

用[l,r]表示点集区间,

有2个要点

1.A,B , C的关系

(1)

(2)


2.i,j的调换

可从下图看出










#include<cstdio>
#include<iostream>
#include<cstdlib>
#include<cstring>
#include<cmath>
#include<functional>
#include<algorithm>
#include<cctype>
using namespace std;
#define MAXN (1000+10)
#define MAXXi (10000+10)
#define eps (1e-10)
const double pi=3.1415926;
int sqr(int x) {return x*x;}
struct P
{
	int x,y;
	P(){}
	P(int _x,int _y):x(_x),y(_y){}
	friend istream& operator>>(istream &cin,P &a)
	{
		cin>>a.x>>a.y;
		return cin;
	}
	friend bool operator<(const P a,const P b){return (a.x==b.x)?a.y<b.y:a.x<b.x;}
	friend bool operator>(const P a,const P b){return (a.x==b.x)?a.y>b.y:a.x>b.x;}
}a[MAXN],st[MAXN];
double dis(P A,P B)
{
	return sqrt((double)sqr(A.x-B.x)+sqr(A.y-B.y));
}
struct V
{
	int x,y;
	V(){}
	V(int _x,int _y):x(_x),y(_y){}
	V(P a,P b):x(b.x-a.x),y(b.y-a.y){}
	friend int operator*(V a,V b)
	{
		return a.x*b.y-a.y*b.x;
	}
};
int n,l,size=0;
double s[MAXN]={0.0};
void hull(int l,int r,P A,P B)
{
	int p=l;
	for (int k=l;k<=r;k++)
		if (s[p]<s[k]||s[p]==s[k]&&a[p]<a[k]) p=k;
	P C=a[p];
	int i=l-1,j=r+1;
	for (int k=l;k<=r;k++)
	{
		s[++i]=V(a[k],A)*V(a[k],C);
		if (s[i]>0) /*Right*/ swap(a[i],a[k]); else i--;
	}
	for (int k=r;k>=l;k--)
	{
		s[--j]=V(a[k],C)*V(a[k],B);
		if (s[j]>0) /*Right*/ swap(a[j],a[k]); else j++;
	}
	if (l<=i) hull(l,i,A,C);
	st[++size]=C;
	if (j<=r) hull(j,r,C,B);
}
int main()
{
//	freopen("poj1113.in","r",stdin);
	cin>>n>>l;
	for (int i=1;i<=n;i++)
		cin>>a[i];
	int pmin=1,pmax=1;
	for (int i=2;i<=n;i++)
	{
		if (a[i]<a[pmin]) pmin=i;
		if (a[i]>a[pmax]) pmax=i;
	}
	swap(a[1],a[pmin]);swap(a[n],a[pmax]);
	st[++size]=a[1];
	hull(2,n,a[1],a[1]);
//	for (int i=1;i<=size;i++) cout<<st[i].x<<' '<<st[i].y<<' '<<endl;
	double ans=0;
	for (int i=1;i<=size;i++) ans+=dis(st[i],st[i+1<=size?i+1:1]);
	cout.setf(ios::fixed);
	cout.precision(0);
	cout<<ans+2*pi*l<<endl;
	return 0;
}