POJ 3171(区间覆盖最小代价)

Language:
Cleaning Shifts
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 2093   Accepted: 735

Description

有N (1 <= N <= 10,000)个区间,求覆盖[M,E](0 <= M <= E <= 86,399)的最小代价.
每个区间的代价为S (where 0 <= S <= 500,000).

Input

第一行3个整数: N, M, E. 

第二行到第n+1行,每行3个数,分别表示第i-1个区间的左端点T1,右端点T2,和代价S.

Output

仅一行表示最小代价,无解输-1.

Sample Input

3 0 4
0 2 3
3 4 2
0 0 1

Sample Output

5

Hint

样例解释
取第一个和第二个区间。

Source

这题是一个Dp问题,先列出Dp方程。
F[i]表示取[M,i]这个区间的代价
显然F[M-1]=0,答案就是F[E]
则方程为F[a[i].T2]=min(F[j])+a[i].S (T1-1<=J<=T2-1)
a[i]按T2从小到大排列;
那么显然a[i]取时,[M,T1-1]已经被前面的给取了,
因为如果被后面的[t1,t2] 取了,那么必有t1<T1 T2<t2, 就没必要取[T1,T2]了。

取最小的数可以用线段树做O(NlogN)。


#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<cmath>
#include<cctype>
#include<iostream>
#include<functional>
#include<algorithm>
using namespace std;
#define MAXN (10000+10)
#define MAXE (86399)
#define MAXS (500000+10)
#define INF (9187201950435737471)
int n,s,e;
struct SegMent
{
	int l,r;
	long long S;
	SegMent(){}
	SegMent(int _l,int _r,long long _S):l(_l),r(_r),S(_S){}
	friend bool operator<(const SegMent a,const SegMent b){return a.r<b.r;}
}a[MAXN];
struct SegMentTree //min()
{
	int n,M;
	long long t[MAXE*10];
	void fillchar(int _n)
	{
		n=_n+2;
		M=1;while (M-2<n) M<<=1;
		memset(t,127,sizeof(t));
	}
	void update(int x)
	{
		for (x>>=1;x;x>>=1) t[x]=min(t[x<<1],t[(x<<1)^1]);
	}
	void insert(int x,long long c)
	{
		x=x+2;
		x+=M;
		if (t[x]>c) {t[x]=c; update(x);	}
	}
	long long find(int l,int r)
	{
		l=l+2;r=r+2;

		l=l-1+M;r=r+1+M;
		long long ans=INF;
		while (l^r^1)
		{
			if (~l&1) ans=min(ans,t[l+1]);
			if (r&1) ans=min(ans,t[r-1]);
			l>>=1;r>>=1;
		}
		return ans;
	}
}t;
int main()
{
//	freopen("poj3171.in","r",stdin);
	scanf("%d%d%d",&n,&s,&e);
	for (int i=1;i<=n;i++) scanf("%d%d%d",&a[i].l,&a[i].r,&a[i].S);
	sort(a+1,a+1+n);
	t.fillchar(e);
	t.insert(s-1,0);
	for (int i=1;i<=n;i++)
	{
		if (a[i].r<s) continue;
		t.insert(a[i].r,t.find(max(s-1,a[i].l-1),a[i].r-1)+a[i].S);
	}
/*	for (int i=t.M;i<=t.M*2;i++) cout<<t.t[i]<<' ';
	cout<<endl;
*/	if (t.t[e+2+t.M]==INF) cout<<"-1n";
	else cout<<t.t[e+2+t.M]<<endl;


	return 0;
}

Tyvj P2065(区间嵌套与统计)

P2065 - 「Poetize10」封印一击

From lydliyudong    Normal (OI)
总时限:10s    内存限制:128MB    代码长度限制:64KB

背景 Background

“圣主applepi于公元2011年9月创造了Nescafe,它在散发了16次光辉之后与公元2011年11月12日被封印为一颗魂珠,贮藏于Nescafe神塔之中。公元2012年9月,圣主带领四大护法重启了Nescafe,如今已经是Nescafe之魂的第30次传播了。不久,它就要被第二次封印,而变成一座神杯……”applepi思索着Nescafe的历史,准备着第二次封印。

描述 Description

Nescafe由n种元素组成(编号为1~n),第i种元素有一个封印区间[ai,bi]。当封印力度E小于ai时,该元素将获得ai的封印能量;当封印力度E在ai到bi之间时,该元素将获得E的封印能量;而当封印力度E大于bi时,该元素将被破坏从而不能获得任何封印能量。现在圣主applepi想选择恰当的E,使得封印获得的总能量尽可能高。为了封印的最后一击尽量完美,就请你写个程序帮他计算一下吧!

输入格式 InputFormat

第一行一个整数N。
接下来N行每行两个整数ai、bi,第i+1行表示第i种元素的封印区间。

输出格式 OutputFormat

两个用空格隔开的整数,第一个数是能够获得最多总能量的封印力度E,第二个数是获得的总能量大小。当存在多个E能够获得最多总能量时,输出最小的E。

样例输入 SampleInput [复制数据]

2
5 10
20 25

样例输出 SampleOutput [复制数据]

10 30

数据范围和注释 Hint

对于 50% 的数据,1<=N<=1000,1<=ai<=bi<=10000。 
对于 100% 的数据,1<=N<=10^5,1<=ai<=bi<=10^9。

时间限制 TimeLimitation

各个测试点1s

区间选取

用Past和In_s维护经过的左右结点,

并由此算出

嵌套数(左-右)

左边的区间数=右

右边的区间数=总-(左-右)-右=总-左

PS:由于是闭区间,需要把-右的时间后延


#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<cmath>
#include<cctype>
#include<iostream>
#include<functional>
#include<algorithm>
using namespace std;
#define MAXN (200000+10)
#define MAXAi (1000000000)
#define NDEBUG
struct segment_node
{
	int l,type;
	friend bool operator<(const segment_node a,const segment_node b){return (a.l!=b.l)?a.l<b.l:a.type<b.type;	}
	friend bool operator==(const segment_node a,const segment_node b){return (a.l==b.l&&a.type==b.type);	}
	friend bool operator!=(const segment_node a,const segment_node b){return (!(a==b));	}

}a[MAXN];
int n;
long long next[MAXN];
int main()
{
	#ifndef NDEBUG
	freopen("segmentbet.in","r",stdin);
	#endif
	memset(a,0,sizeof(a));
	scanf("%d",&n);n<<=1;
	for (int i=1;i<=n;i+=2)
	{
		scanf("%d%d",&a[i].l,&a[i+1].l);
		a[i].type=-1;a[i+1].type=1;
	}
	sort(a+1,a+n+1);
	int in_s=0,minE=0;
	long long ans=0;
	memset(next,0,sizeof(next));
	for (int i=n-1;i>=1;i--)
	{
		next[i]=next[i+1];
		if (a[i+1].type==-1)
			next[i]+=a[i+1].l;
	}
	int j=1,past=0,pastE=0;
	for (int i=1;i<=n;i++)
	{
		if (a[i]!=a[i+1])
		{
			int len=i-j+1;
			j=i+1;
			len*=-a[i].type;
			if (pastE!=a[i].l) {in_s+=past;past=0;}
			if (len>0) in_s+=len;
			else past+=len;

			long long cost=(long long)(long long)in_s*(long long)a[i].l+next[i];
			if (ans<cost)
			{
				ans=cost;
				minE=a[i].l;
			}

		}

	}
	cout<<minE<<' '<<ans<<endl;
	return 0;
}



RQNOJ 601(区间覆盖问题)

查看题目 Show Problem

题目:[NOIP2010]引水入城

问题编号:601


题目描述


在一个遥远的国度,一侧是风景秀美的湖泊,另一侧则是漫无边际的沙漠。该国的行政区划十分特殊,刚好构成一个N 行M 列的矩形,如上图所示,其中每个格子都代表一座城市,每座城市都有一个海拔高度。
为了使居民们都尽可能饮用到清澈的湖水,现在要在某些城市建造水利设施。水利设施有两种,分别为蓄水厂和输水站。蓄水厂的功能是利用水泵将湖泊中的水抽取到所在城市的蓄水池中。因此,只有与湖泊毗邻的第1 行的城市可以建造蓄水厂。而输水站的功能则是通过输水管线利用高度落差,将湖水从高处向低处输送。故一座城市能建造输水站的前提,是存在比它海拔更高且拥有公共边的相邻城市,已经建有水利设施。
由于第N 行的城市靠近沙漠,是该国的干旱区,所以要求其中的每座城市都建有水利设施。那么,这个要求能否满足呢?如果能,请计算最少建造几个蓄水厂;如果不能,求干旱区中不可能建有水利设施的城市数目。

【样例1 说明】
只需要在海拔为9 的那座城市中建造蓄水厂,即可满足要求。
【样例2 说明】

上图中,在3 个粗线框出的城市中建造蓄水厂,可以满足要求。以这3 个蓄水厂为源头
在干旱区中建造的输水站分别用3 种颜色标出。当然,建造方法可能不唯一。

【数据范围】

输入格式

输入文件的每行中两个数之间用一个空格隔开。
输入的第一行是两个正整数N 和M,表示矩形的规模。
接下来N 行,每行M 个正整数,依次代表每座城市的海拔高度。

输出格式

输出有两行。如果能满足要求,输出的第一行是整数1,第二行是一个整数,代表最少
建造几个蓄水厂;如果不能满足要求,输出的第一行是整数0,第二行是一个整数,代表有
几座干旱区中的城市不可能建有水利设施。

样例输入

【输入输出样例1】
2 5
9 1 5 4 3
8 7 6 1 2

【输入输出样例2】
3 6
8 4 5 6 4 4
7 3 4 3 3 3
3 2 2 1 1 2

样例输出

【输入输出样例1】
1
1

【输入输出样例2】
1
3

先floodfill,判定有无解。

若有解,则没个蓄水站必然会覆盖的区间一定连续

下面这幅图说明了这一点:

显然水无论如何也无法流进中间的区间,证毕。

注:下文使用的区间覆盖假定一定有解,若无解则需另加考虑。

Another PS:http://lhz1208.diandian.com/post/2011-11-11/6674864

Program desert;
const
   maxn=501;
   maxm=501;
   INF=2139062143;
var
   n,m,i,j,tot,nowl,maxr:longint;
   height:array[0..maxn,0..maxm] of longint;
   l,r:array[1..maxm] of longint;

   b:array[0..maxn,0..maxm] of boolean;
Procedure swap(var a,b:longint);
var
   p:longint;
begin
   p:=a;a:=b;b:=p;
end;
function max(a,b:longint):longint;
begin
   if a<b then exit(b) else exit(a);
end;
Procedure floodfill(x,y:longint);
var
   i,j:longint;
begin
   b[x,y]:=true;
   if not(b[x+1,y]) and (height[x+1,y]<height[x,y]) then floodfill(x+1,y);
   if not(b[x-1,y]) and (height[x-1,y]<height[x,y]) then floodfill(x-1,y);
   if not(b[x,y+1]) and (height[x,y+1]<height[x,y]) then floodfill(x,y+1);
   if not(b[x,y-1]) and (height[x,y-1]<height[x,y]) then floodfill(x,y-1);
end;
Procedure qsort(_l,_r:longint);
var
   i,j,m,p:longint;
begin
   i:=_l;
   j:=_r;
   m:=l[(i+j) div 2];
   repeat
      while (l[i]<m) do inc(i);
      while (l[j]>m) do dec(j);
      if i<=j then
      begin
         swap(l[i],l[j]);
         swap(r[i],r[j]);
         inc(i); dec(j);
      end;
   until i>j;
   if (_l<j) then qsort(_l,j);
   if (i<_r) then qsort(i,_r);
end;
begin
   read(n,m);
   fillchar(b,sizeof(b),false);
   fillchar(height,sizeof(height),127);
   for i:=1 to n do
      for j:=1 to m do
         read(height[i,j]);

   tot:=0;
   for i:=1 to m do floodfill(1,i);

   for i:=1 to m do if not(b[n,i]) then inc(tot);
   if tot>0 then
   begin
      writeln('0');
      writeln(tot);
      halt;
   end;

   for i:=1 to m do
   begin
      fillchar(b,sizeof(b),false);
      floodfill(1,i);
      l[i]:=1;
      r[i]:=m;
      while not(b[n,l[i]]) and (l[i]<m) do inc(l[i]);
      while not(b[n,r[i]]) and (r[i]>1) do dec(r[i]);
      if not(b[n,l[i]]) then begin l[i]:=0; r[i]:=0; end;
   end;
   qsort(1,m);


   nowl:=1; tot:=0; maxr:=0;
   for i:=1 to m do
   begin
      if (l[i]<=nowl) then maxr:=max(maxr,r[i])
      else
      begin
         inc(tot);
         nowl:=maxr+1;
         maxr:=r[i];
      end;
   end;
   if nowl<m+1 then inc(tot);
   writeln('1');
   writeln(tot);





end.