舞蹈课 (C++堆的优先级与重载)

第三题:舞蹈课(dancingLessons)

时间限制:1秒

内存限制:256MB

输入:dancingLessons.in

输出:dancingLessons.out

问题描述

有n个人参加一个舞蹈课。每个人的舞蹈技术由整数来决定。在舞蹈课的开始,他们从左到右站成一排。当这一排中至少有一对相邻的异性时,舞蹈技术相差最小的那一对会出列并开始跳舞。如果相差最小的不止一对,那么最左边的那一对出列。一对异性出列之后,队伍中的空白按原顺序补上(即:若队伍为ABCD,那么BC出列之后队伍变为AD)。舞蹈技术相差最小即是的绝对值最小。

你的任务是,模拟以上过程,确定跳舞的配对及顺序。

输入

第一行为正整数:队伍中的人数。下一行包含n个字符B或者G,B代表男,G代表女。下一行为n个整数。所有信息按照从左到右的顺序给出。在50%的数据中,。

输出

第一行:出列的总对数k。接下来输出k行,每行是两个整数。按跳舞顺序输出,两个整数代表这一对舞伴的编号(按输入顺序从左往右1至n编号)。请先输出较小的整数,再输出较大的整数。

样例输入

4

BGBG

4 2 4 3

样例输出

2

3 4

1 2

样例输入

4

BGBB

1 1 2 3

样例输出

1

1 2

堆的操作

--堆默认为小根堆(重载Operator<) 小的放前面

注意此处用greater - 大根堆

#include<cstdio>
#include<cstring>
#include<queue>
#include<cmath>
#include<cstdlib>
#include<iostream>
#include<functional>
#include<algorithm>
using namespace std;
#define MAXN (200000 + 10)
#define MAXAI (10000000 + 10)
int n;
char s[MAXN];
int a[MAXN];
bool b[MAXN];
struct pair2
{
	int x,y,w;
}ans[MAXN];

bool operator>(const pair2 a,const pair2 b)
{
	if (a.w==b.w) return a.x>b.x;
	return a.w>b.w;
}
void cout_pair(const pair2 a)
{
	printf("%d %dn",a.x,a.y);
}
priority_queue <pair2, vector<pair2>, greater<pair2> > q;
void push(int x,int y)
{
	pair2 now;
	now.x=x;
	now.y=y;
	now.w=abs(a[x]-a[y]);
	q.push(now);
//	cout<<"add "<<now.x<<' '<<now.y<<' '<<now.w<<'n';
}
int main()
{
	freopen("dancingLessons.in","r",stdin);
	freopen("dancingLessons.out","w",stdout);


	scanf("%dn%s",&n,s);
	for (int i=1;i<=n;i++) scanf("%d",&a[i]);
	memset(b,0,sizeof(b));
	for (int i=1;i<n;i++)
		if (s[i-1]!=s[i]) push(i,i+1);
	int tot=0;
	while (!q.empty())
	{
		pair2 now=q.top();
//		cout_pair(now);
		q.pop();
		if (b[now.x]||b[now.y]) continue;
		b[now.x]=1;
		b[now.y]=1;
		ans[++tot]=now;
		int l=now.x-1,r=now.y+1;
		if (l<1||r>n) continue;
		while (l>1&&b[l]) l--;
		while (r<n&&b[r]) r++;
		if (b[l]||b[r]) continue;
		if (s[l-1]!=s[r-1]) push(l,r);


	}

	printf("%dn",tot);
	for (int i=1;i<=tot;i++) cout_pair(ans[i]);

//	while (1);
	return 0;
}

BYSBZ 2748(音量调节-01背包)

第一题:音量调节 (changingsounds)

时间限制:1秒

空间限制:64 MB

输入:changingsounds.in

输出:changingsounds.out

问题描述

一个吉他手准备参加一场演出。他不喜欢在演出时始终使用同一个音量,所以他决定每一首歌之前他都要改变一次音量。在演出开始之前,他已经做好了一个列表,里面写着在每首歌开始之前他想要改变的音量是多少。每一次改变音量,他可以选择调高也可以调低。

音量用一个整数描述。输入文件中给定整数beginLevel,代表吉他刚开始的音量,以及整数maxLevel,代表吉他的最大音量。音量不能小于0也不能大于maxLevel。输入文件中还给定了n个整数,表示在第i首歌开始之前吉他手想要改变的音量是多少。

吉他手想以最大的音量演奏最后一首歌,你的任务是找到这个最大音量是多少。

输入

第一行依次为三个整数:n, beginLevel, maxlevel。

第二行依次为n个整数:。

限制:,,,。

输出

输出演奏最后一首歌的最大音量。如果吉他手无法避免音量低于0或者高于maxLevel,输出-1。

样例输入

3 5 10

5 3 7

样例输出

10

样例输入

4 8 20

一定要读题啊!!

这题说的是——每次一定换,没说前后不能到一个音量。

#include<cstdio>
#include<cstring>
#include<queue>
#include<cmath>
#include<cstdlib>
#include<iostream>
#include<functional>
#include<algorithm>
#include<stack>
using namespace std;
#define MAXN  (50 + 10)
#define MAXMAXLEVEL (1000+1)
int n,start,maxlevel,a[MAXN];
bool f[MAXN][MAXMAXLEVEL];
int main()
{
//  freopen("changingsounds.in","r",stdin);
//  freopen("changingsounds.out","w",stdout);

    memset(f,0,sizeof(f));

    scanf("%d%d%d",&n,&start,&maxlevel);
    for (int i=1;i<=n;i++) scanf("%d",&a[i]);
    f[0][start]=1;
    for (int i=1;i<=n;i++)
        for (int j=0;j<=maxlevel;j++)
        {
            f[i][j]=j-a[i]>=0? f[i-1][j-a[i]] : 0;
            f[i][j]=j+a[i]<=maxlevel? f[i-1][j+a[i]]||f[i][j] : f[i][j];



        }
    int ans=maxlevel;
    while (ans>=0&&!f[n][ans]) ans--;
    cout<<ans<<endl;




//  while (1);
    return 0;
}